eLog and document display issues

Incident Report for Florence Healthcare Status Page

Resolved

The issue affecting document and eLog viewing functionality has been successfully resolved. All documents and eLogs now display correctly.
Posted May 07, 2026 - 18:00 EDT

Investigating

We are currently experiencing issues with document and eLog viewing functionality. Users may encounter problems loading or properly displaying documents and eLogs across eBinders.
Posted May 07, 2026 - 14:04 EDT
This incident affected: eBinders (eBinder).