Service Temporarily Unavailable

Incident Report for Florence Healthcare Status Page

Resolved

All services are back to operational.
Posted Aug 21, 2025 - 17:00 EDT

Identified

We have identified an issue related to our authentication provider and are working towards a full resolution.
Posted Aug 21, 2025 - 15:00 EDT

Investigating

We are currently investigating the issue.
Posted Aug 21, 2025 - 13:59 EDT
This incident affected: eBinders (eBinder), Authentication (Authentication), SiteLink (SiteLink), and eConsent (eConsent).