Document Viewer issue affecting the display of multi-page forms in our system.

Incident Report for Florence Healthcare Status Page

Resolved

The incident has been resolved.
Posted Jul 03, 2025 - 15:09 EDT

Update

We have deployed a fix and are monitoring the situation
Posted Jul 03, 2025 - 10:00 EDT

Identified

We have identified the issue. Resolution is in validation phase.
Posted Jul 03, 2025 - 03:17 EDT

Investigating

When uploading a form that includes multiple pages, the last page may appear blank in the system view even though the text is correctly saved in our system and included in downloads.

This is strictly a display issue caused by a third-party document viewer and does not impact the integrity of your documents. There is no data loss related to this issue.

We are investigating the issue.
Posted Jul 02, 2025 - 13:01 EDT
This incident affected: eBinders (eBinder).