Email Import feature is not working - Emails not being uploaded to eBinders

Incident Report for Florence Healthcare Status Page

Resolved

The necessary configuration changes have been made, and new email imports are now being uploaded as expected along with the expected email confirmations or failure notifications.
Posted Jul 31, 2025 - 13:51 EDT

Identified

The email import feature is currently not working, and failure notifications are not being sent as expected. This is due to an unexpected configuration change by our third-party email provider. Our team has identified the issue and is working on a fix. Please avoid using the email import feature until this issue is resolved.
Posted Jul 31, 2025 - 12:24 EDT
This incident affected: eBinders (Document Upload).