System-wide issues

Incident Report for Florence Healthcare Status Page

Resolved

The incident has been resolved and all systems are back to operational.
Posted Sep 29, 2025 - 11:46 EDT

Identified

The issue has been identified and our Engineering team is on it.
Posted Sep 29, 2025 - 11:00 EDT
This incident affected: eBinders (eBinder), Authentication (Authentication), SiteLink (SiteLink), and eConsent (eConsent).