Performance issues in eBinders

Incident Report for Florence Healthcare Status Page

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 13:32 EDT

Monitoring

Due to a backend update, some users may experience performance issues such as password reset loops, blank pages, or page reloading in our eBinders Production environment.
We have identified the issue and are actively monitoring the situation. We will provide an update as soon as it is resolved.
Posted Jul 18, 2025 - 10:11 EDT
This incident affected: eBinders (eBinder) and Authentication (Authentication).