All Florence services have fully recovered and are now operating normally. Our team has confirmed that AWS services have been fully restored, and all Florence products are functioning as expected. Thank you for your patience while we worked through this issue.
Posted Oct 21, 2025 - 13:00 EDT
Update
Our Florence team is actively working to mitigate the impact of the issues stemming from the world-wide AWS (Amazon Web Services) outage. We’re seeing steady improvement, with most operations now performing as expected. We’ll continue to closely monitor the situation and coordinate with AWS until all services are fully restored. Thank you for your continued patience and understanding as we work to ensure full recovery.
Posted Oct 20, 2025 - 09:03 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 06:53 EDT
Monitoring
We’re currently experiencing intermittent service issues due to an ongoing world wide network outage of a third-party vendor affecting several of our core systems.
Posted Oct 20, 2025 - 04:15 EDT
This incident affected: eBinders (eBinder, Reports) and AWS s3-us-east-2.