The issue was caused by a third-party vendor that we rely on for authentication. Our systems are now fully operational. We will continue to work on minimizing the risk of future disruptions.
Posted Oct 02, 2025 - 11:10 EDT
Monitoring
We have identified the issue, and performance has improved. Our team is continuing to monitor the situation to ensure stability.
Posted Oct 02, 2025 - 10:52 EDT
Investigating
We are currently investigating this issue.
Posted Oct 02, 2025 - 10:34 EDT
This incident affected: eBinders (eBinder), Authentication (Authentication), SiteLink (SiteLink), and eConsent (eConsent).